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Pulser Description 

The Pulser device was developed to enable convenient visual programming of pulse trains 
for Optogenetics experiments from Windows PCs. The software enables the user to 
visually program trains of pulses, to create groups of trains and to add various triggering 
conditions as described in the following pages. The Pulser hardware unit is intended to be 
used with LED or laser light sources capable of fast switching by TTL pulses 
For general lab usage the Pulser hardware can be operated from LabView, Matlab, 
HyperTerminal and many other software packages. The software is compatible with 
windows XP, VISTA, Win.7 and Win.8. 

Health and Safety 

Prizmatix products are NOT authorized for use as components in life support devices or 
systems. 

The Pulser is intended for use as 
laboratory equipment only. 

It is not cleared or authorized for clinical 
use. 

 

Any maintenance should ONLY be performed by a technician authorized by Prizmatix.   
Cellular phones or other radio transmitters should not be used within the vicinity of the 
unit. 

Important notice 

Prizmatix is a registered trademark of Prizmatix Ltd. 2007-2015. All rights reserved. 
All other product names or trademarks are property of their respective owners. 
Information in this manual is subject to change without notice and does not represent a 
commitment on the part of the vendor. The software described in this manual is furnished 
under a license agreement and may be used or copied only in accordance with the terms 
of the agreement. The material in this manual is copyrighted and may not be reproduced 
or electronically distributed without written permission from the copyright holder. 
Prizmatix Ltd. provides this publication "as is" without warranty of any kind, either express 
or implied, including but not limited to the implied warranties or conditions of 
merchantability or fitness for a particular purpose. In no event shall Prizmatix Ltd. be 
liable for any loss of profits, loss of business, loss of use or data, interruption of business, 
or for indirect, special, incidental, or consequential damages of any kind, even if Prizmatix 
Ltd. has been advised of the possibility of such damages arising from any defect or error 
in this publication or in the Pulser firmware or software. 
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Device Setup 

Remove the device from packaging and inspect for loose components or any signs of 
damage. Notify Prizmatix if the device appears damaged in any way: do not install a 
damaged device.  

Package Contents  

Pulser  USB-A to USB-B Cable 

  

Software Installation CD BNC-BNC Cable 

  

 

 

 

 Item Description QTY 

1 Pulser The USB-TTL Interface unit 1 

2 USB Cable 
USB Type-A to USB Type-B cable for 
connection of Pulser unit to PC 

1 

3 BNC-BNC Cable 
BNC-BNC cable for connection of the USB-
TTL Interface to Prizmatix LED controller 

1 

4 CD with Software Pulser software and drivers on CD 1 
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Possible Pulser setups:  
(A) Simple setup for Optogenetics.  

Use this setup with Operation Mode (0). See Trigger Operation Modes 
section below 

(B) Setup for Optogenetics with external trigger device 
Use this setup with Operation Mode (1), (2) and (3). See Trigger Operation 
Modes section below 
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System overview 
 

 
 

Pulser front panel  
 

 

 

 
 

Pulser back panel 
 

 

General Specifications 

Maximum output current:  40mA 
Dimensions:    25 x 50 x 110 (W x H x L) 
Input Connector:  USB Type A 
TTL Output Connector: BNC (standard TTL levels) 
TTL Input Connector:  BNC (standard TTL levels) 
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Software Setup 

The Pulser system setup is performed in two steps: 

 Setup of Prizmatix Pulser PC software 

 Setup of Pulser device drivers 

Do not connect the Pulser device to the 
computer until the software setup 

process is complete 

Setup of Prizmatix Pulser PC Software 

Insert the CD with the installation software into the CD-ROM driver of the computer. 
Browse the CD and find the setup.exe file. Run the setup.exe file and follow the 
instructions as they appear during the setup process and then re-boot the system to 
complete the software installation. 
Note: The setup will install NI-VISA (National Instruments' Virtual Instrument Software 
Architecture). Pulser PC software uses NI-VISA to communicate with the Pulser 
hardware via USB serial port. 
 

Setup of Pulser Device Drivers 

After successful setup of the Prizmatix Pulser software, connect the Pulser to the 
computer with the supplied USB cable.  
Windows will begin the standard driver installation procedure and after a few moments 
the process will fail.  
Click on the Start Menu, and open up Control Panel 
Navigate to System and Security. Next, click on System. Once the System window is up, 
open the Device Manager. 
An alternative way to get to device manager is to right-click on the “My Computer” icon 
on the desktop and choose “Manage” from the menu. 
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Choose Device Manager on the left panel and look for “?” unknown device in the list in 
the right panel. 

 

 

Right click on the unknown device and choose the "Update Driver Software" option. 
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From now will be some difference between Win XP and Win VISTA/7/8 systems.. For 
installation on Win XP see Appendix A 
The Update Driver Software dialog will appear: 

 

Choose “Browse my computer…” 
 
On next screen in section “Search for driver software in this location” Browse my 
computer to driver software: 

C:\Program Files (x86)\Prizmatix Pulser\Drivers and click on Next. 

 
 

A new window will appear, immediately followed by a window of Windows Security. 
Click “Install” 
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After few moments the installation will be completed and a dialog box will appear: 
 
 

 
 
Note the COM port number displayed at the top of the dialog box (COM18 in this 
example). Click on “Close” to complete the setup. 

Now open the Device Manager. The Prizmatix Pulser device will be found in the list in 
the right panel. Please notice the COM port number (18 in this example). 
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Once the driver installation is complete the Pulser software can be used 
 

System Usage 

Choose Pulser from Start menu to launch the Pulser software. 

 

The main Pulser screen will appear. Select the appropriate COM port from the list (18 in 
this example). See above on finding COM port number by browsing Device Manager. If 
the appropriate COM port number does not appear at the list choose “Refresh” to allow 
the system to rescan available COM ports.  
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The Pulser Windows software features a simple Graphical User Interface (GUI) for 
configuring multiple single or bi-phasic pulses in multiple trains. Go to the Train Setting 
tab to access these settings:  

 

 
 
The trains set at Train Setting tab create a Group (a group of Trains). The Group 
properties can be viewed at Group Settings tab: 
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For initial testing of the Pulser device, connect the Pulser TTL Out to TTL input connector 
on the Prizmatix LED Current Controller and set the following parameters: 
On Train Settings Tab: 

 Total # (numbers) of Trains (for example 10) 

 P1D – Pulse 1 Duration [msec] (for example 200) 

 P1I – Pulse 1 Interval [msec] (for example 200) 

 Select Operation Mode: (0) Execute pulse sequence after START 
 

 
 
 
On Group Settings Tab: 

 Set Total # (number) of Groups (for example 1)  
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Notes: 

 “Group Duration” is calculated from the values assigned at the “Train Setting” 
tab. 

 “Group Interval” field is not active since the current setting of “Total # of 
Groups” is 1. If you change the “Total # of Groups” value to larger than 1 the 
“Group Interval” field will become active. 

 “Total Sequence Time” is calculated from the values assigned to all other fields. 
 

The small green indicator LED light on the Pulser back panel will start to blink at about 1 
Hz, indicating that the Pulser device is ready and awaiting instructions to be sent from 
the Prizmatix Pulser software. 
 
Press ”Start” button in the software window. The small green indicator LED light will 
stop blinking while the TTL Out will send the programmed pulses to the LED driver TTL 
input. When the pulse train is finished the green LED indicator will resume blinking at 
about 1 Hz. 
 

 
 

Software Menu 

The Pulser software features File and Help menus. 

 
 
File>Update Firmware 
Displays a dialog box enabling a user to update the Pulser microcontroller firmware. 
Please don’t use this menu unless you received explicit instructions from the Prizmatix 
technical team. 
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File>Exit 
Exit the Pulser software. The software saves the last Train and Group setting before 
exiting. 
 
Help> User Manual 
Displays the user manual PDF file. 
 
Help> Prizmatix Website 
Opens the Prizmatix website (www.prizmatix.com) at default browser. 
 
Help> About Pulser 
Displays a dialog box with information. 
 

Trigger Operation Modes 

Prizmatix Pulser enables the user to choose one of four Operation Modes: 
(0) Execute pulse sequence after START 
(1) Execute pulse sequence once after trigger(s) 
(2) Execute pulse sequence each time after trigger(s) 
(3) Execute pulse sequence after trigger HIGH, then stop when LOW 

 

 
 

Mode (0): Execute pulse sequence after START 

In this mode the sequence will not depend on the trigger input state. The pulse 
sequence will start after clicking on “Start” button in the software window.  
The small indicator LED light on Pulser device will blink at about 1 Hz while waiting for 
the click on “Start” button. During the pulse train the small LED indicator will stop 
blinking. 
To terminate operation mode (0) press “STOP” button on the Pulser PC software. 

Mode (1): Execute pulse sequence once after trigger(s) 

In this mode the user connects the TTL trigger cable from the triggering device to the 
“Trigger In” BNC connector. After clicking the software “Start” button, the green LED 
indicator will start blinking at a rapid rate (about 10 Hz) indicating that the Pulser is 

http://www.prizmatix.com/
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waiting for a "Trigger In" signal. When “Trigger In” receives TTL High, the green indicator 
LED will stop blinking and the TTL Out will send the programmed pulses to the LED 
driver TTL input. When the pulse train will be finished the green LED indicator will 
resume blinking at about 1 Hz. Additional TTL High signal at “Trigger In” will not restart 
the pulse sequence until the user will click the software “Start” button and “Trigger In” 
will receive TTL High signal. 
To terminate operation mode (1) press “STOP” button on the Pulser PC software. 
User can specify number of triggers the “Trigger In” should receive to start the sequence 
of programmed pulses at “TTL Out” 
 

 
 

Mode (2): Execute pulse sequence each time after trigger(s) 

Connect the TTL trigger cable from the triggering device to the “Trigger In” BNC 
connector. After clicking on the software “Start” button, the green LED indicator will 
start blinking at a rapid rate (about 10 Hz) indicating that the Pulser is waiting for a 
“Trigger In” signal. When the “Trigger In” receives TTL High, the green LED indicator will 
stop blinking while the TTL Out will send the programmed pulses to the LED driver TTL 
input. When the pulse train is finished the green LED indicator will resume blinking at 
about 1 Hz. An additional TTL High signal at "Trigger In" will re-initialize the programmed 
pulse sequence.  
To terminate operation mode (2) press “STOP” button on the Pulser PC software. 
User can specify number of triggers the “Trigger In” should receive to start the sequence 
of programmed pulses at “TTL Out” 
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Mode (3): Execute pulse sequence after trigger HIGH, then stop when LOW 

Connect the TTL trigger cable from the triggering device to the “Trigger In” BNC 
connector. After clicking on the software “Start” button the green LED indicator will turn 
OFF until “Trigger In” receives TTL High. When Trigger In will receive TTL High level, the 
Pulser will generate the user defined pulse sequence until the "Trigger In" will return to 
TTL Low level. During generation of the pulse sequence the LED indicator will be 
continuously ON.  
To terminate operation mode (3) press “STOP” button on the Pulser PC software.  

How to Call Pulser Hardware from Other Software 

The Pulser can be used with Matlab, LabView and any HyperTerminal-like software 
capable of sending and receiving simple ASCII commands over a USB interface. 
In order to send commands to the Pulser the COM port should be configured with 
following settings:  

Bits per second: 57600 
Data bits: 8 
Parity: None 
Stop Bits: 1 
Flow Control: None 

 

The setting can be changed at Device Manager (see Pages 9 and 12). Right Click the 
Prizmatix DRV device and select Properties from the list: 
 

 
 

The COM Port settings can be configured at the Port Settings tab: 
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The Pulser can accept commands send to the serial COM port in following format: 
TNT,BI,P1D,P1I,P2D,P2I,TNG,GI,OM,NoT@ 

where 
TNT – Total # of Trains 

BI – Train Interval [msec] 

P1D – Pulse 1 Duration [msec] 

P1I – Pulse 1 Interval [msec] 

P2D – Pulse 2 Duration [msec] 

P2I – Pulse 2 Interval [msec] 

TNG – Total # of Groups 

GI – Group Interval [sec] 

OM – Operation mode [0, 1, 2, 3] 

NoT – Number of Triggers [1, 2…] 

@ - character “@” indicate end of command. 

Notes:  

 No comma “,”  is needed before "@" character 

 All sent numbers should be integers (whole numbers)  

 At the end of a string there's no need to send “End of Line”, “Carriage Return” or 
any other termination character 
 

Examples: 
100,1,200,300,300,250,1,0,0,1@ 
25,50,250,250,0,0,10,50,2,5@ 
 
While working at operation modes (0) or (1) after the Pulser will finish an operation it 
will send a Finish command to the PC: 
F     (Capital F) 
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If Pulser is operated in operation mode (2) or (3) it will not send a Finish command as it 
always waits for new trigger(s). The execution of operation mode (2) or (3) can be 
terminated by Stop command as described below. 
 
The Pulser can accept a Stop command to terminate an operation. The Stop command 
can be sent to the Pulser in operation modes (0) - (3). The Stop command format is:  
S EOL   (Capital S followed by End of Line) 
After the Pulser will terminate an operation it will send to the PC: 
A     (Capital A) 

Appendix A: Setup of Pulser Device Drivers on Win. XP PC System 

In order to setup the Pulser Device Drivers on Windows XP system please start the setup 
procedure according to section “Setup of Pulser Device Drivers” above up to a  referral 
to Appendix A. and proceed from here: 
The Hardware Update Wizard window will appear: 
 

 
 

Choose “No, not this time” and click “Next”. At the next screen choose “Install from a 
list or specific location” and click “Next”. 
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On the next screen choose “Include this location in the search” and browse My 
Computer for driver software at: 

C:\Program Files\Prizmatix Pulser\Drivers and click on Next. 

 

A new window will appear: 

 

Immediately followed by another window, click “Continue Anyway”: 
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After few seconds the procedure will be completed and a final window appear: 

  

Click on “Finish” to complete the setup. 

Once the driver installation is complete the Pulser software can be used. 

 

Appendix B: Known Software Issues 

Error 8 

Problem: After pressing EXIT button you may receive an Error Message Box: “Error 8 
occurred at Open/Create/Replace File…”.  
Solution: The problem is due a file-save permissions issue. It occurs during EXIT when 
Pulser software tries to save the current software configuration into a file.  
We need to change the Privilege Level of the Pulser.EXE file: 
Press Start button, Right click the Pulser and select Properties from the drop-down 
menu 
 

 

Click on Open File Location button to view the Pulser.exe file in the folder.  
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Right click the Pulser.exe file and select Properties from the drop-down menu 

 
 

On Compatibility Tab of Properties dialog box click on Change Setting for all users check 
"Run this program as an Administrator" and press OK on both dialog boxes: 
 

 
 

From now the Pulser.exe will have permission to save configuration files and the Error 
message will not appear again. 
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Appendix C: Updating Pulser Firmware 

 

Don’t perform Firmware Update unless you received explicit  
Instructions from the Prizmatix technical team. 

 

Open the Update Firmware dialog by selecting File>Update Firmware from 
Pulser software menu. 
 

 
 

1) Select the correct COM Port (COM18 in this example). See section “Setup of 
Pulser Device Drivers” in this manual for details how to find the Pulser COM port. 
 

2) Click “Select Firmware Updating File (*.hex)” button and browse to  
C:\Program Files (x86)\Prizmatix Pulser 2.3\Firmware\ 
Pulser_05_2.cpp.hex 

or other appropriate  *.hex  file. 
3) Click “Start Update” button to begin update. 

 
When the update is completed successfully the following dialog box will appear: 

 

 
 

Click “Close”. 
Your Pulser is now updated with the latest firmware and ready to go. 


